We are investigating

Minor incident Document Checker
2022-08-09 09:20 PM -04 · 10 hours, 51 minutes

Updates

Resolved

We found the root of the issue and we have fixed it.

August 10, 2022 · 08:11 AM -04
Investigating

We have detected issues and we are currently investigating, we’ll update you soon.

August 10, 2022 · 07:35 AM -04

← Back